Black Lives Matter. Please consider donating to Black Girls Code today.

I am not able to generating .exe file by using pyinstaller in dash? can you please help any one on this issue?

I am able to generating .exe for normal python files, but not able to generating .exe dash files, facing this issue today only.
I am facing issues related to app.run_server().

Error Log:
Traceback (most recent call last):
File “c:\users\lcladmin\anaconda3\lib\runpy.py”, line 193, in run_module_as_main
main”, mod_spec)
File “c:\users\lcladmin\anaconda3\lib\runpy.py”, line 85, in run_code
exec(code, run_globals)
File "C:\Users\LCLADMIN\Anaconda3\Scripts\pyinstaller.exe_main
.py", line 9, in
File "c:\users\lcladmin\anaconda3\lib\site-packages\PyInstaller_main
.py", line 111, in run
run_build(pyi_config, spec_file, **vars(args))
File “c:\users\lcladmin\anaconda3\lib\site-packages\PyInstaller_main_.py”, line 63, in run_build
PyInstaller.building.build_main.main(pyi_config, spec_file, **kwargs)
File “c:\users\lcladmin\anaconda3\lib\site-packages\PyInstaller\building\build_main.py”, line 838, in main
build(specfile, kw.get(‘distpath’), kw.get(‘workpath’), kw.get(‘clean_build’))
File “c:\users\lcladmin\anaconda3\lib\site-packages\PyInstaller\building\build_main.py”, line 784, in build
exec(text, spec_namespace)
File “”, line 17, in
File “c:\users\lcladmin\anaconda3\lib\ast.py”, line 266, in generic_visit
for field, value in iter_fields(node):
File “c:\users\lcladmin\anaconda3\lib\ast.py”, line 179, in iter_fields
yield field, getattr(node, field)
RecursionError: maximum recursion depth exceeded while calling a Python object

Is it possible to generate .exe using pyinstaller to dash files ?

add the following code please:

import sys
sys.setrecursionlimit(1000000)

Thanks for Your reply

I added above lines and tested, but getting same error.
Can you please provide any other solution for this problem

please comment any one, why its failing .exe while running plotly dash files ony, I cross verified normal python files, its generating .exe, but dash not supporting to generate .exe. This is happening from last week onwards only.

After creating .exe

facing following issue

image

please reply any one!

meet the exactly the same issue, I only ‘import plotly’ in the python code, nothing else, but still got the same error

“import sys
sys.setrecursionlimit(1000000)”

add this code in spec file start, for me it works