How to remove debug menu?

This thing (if I’ve done the image upload correctly):
Screen Shot 2023-02-19 at 3.56.10 PM

How do I get rid of it? I’ve googled and people say to set debug to False, but I’ve done that. I invoke as follows:

app.run_server(host=“”, debug=False, port=8000)

Reason for needing removal: it always covers something up. Moving it probably won’t work either. There’s no good place for that button. :joy: I need the ability to toggle it on and off.

Hi @graymalk , I can’t reproduce this. Are you sure you restarted the app?

I definitely restarted the app. I even just tried again now and got the same result. So are you saying that setting debug to False works properly for you and gets rid of that button?

Yes, it does. Did you restart your browser?

Ah, I can add something: it seems to work as expected in Chrome on desktop, but not in Safari on iOS. I mostly use this app on my iPhone so naturally I noticed that first and not what was happening in Chrome.

Yes, and also refreshed. It’s happening in iOS in Safari.

Looks like you got it figured out but if you needed you could also hide that component via the custom.css file:

.dash-debug-menu__outer, .dash-debug-menu {
    display: none !important;

I did this lol:

.dash-debug-menu__outer {
visibility: hidden !important;

.dash-debug-menu {
visibility: hidden !important;

Works like a charm, though I’ll have to get the app to log everything to log files instead of the GUI. edited typos