✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
🐇 Announcing Dash VTK for 3d simulation graphics. Check out the March webinar.

How can we make dash accessible to multiple users

I am new to plotly & dash.

I am thinking of building a dash app and sharing among our internal group. We are using some remote windows machines. I tried the simple bar example in the tutorial. By the following setting, I was able to visit the application.

if name == ‘main’:
app.run_server(debug=‘False’, host=’.,,’, port = 2018, threaded=True)

However, no two users can visit this application at the same time. Any suggestions? Thanks!

I found this post:

By following instruction above (using waitress), I was able to get app work. However, I find the following issues: i.e. is not working; and for some users chrome is not working (page will forever show loading). I have asked some of my colleagues to test this. This is really wired… any suggestion?

Hm, that’s odd. I’m not sure what could be going on here. Have you tried it with a simple example (so that you know that it’s not a deeper issue with the app)? Also, when it is infinitely loading, are there any errors in the browser’s console or in the terminal?

@chriddyp I was trying a very simple example (bar plot). There is no error when trying loading. It could be proxy problem. I will try again and make sure all users have exactly the same settings for browsers.

A quick question, does dash has any restriction on version/type of browsers? It is odd that one of users who is able to access app via chrome, while not use windows ie…

@chriddyp I am confirming that the app is not accessible using MS IE 11, while chrome is OK. The IE shows ‘loading’, and no error message. My app is deployed at a remote window server machine(our company cloud).Unfortunately, I am not allowed to send any data outside our company.

This might not be helpful in solving the problem. But I am not allowed to send any data outside our company. Hopefully, some other folkers having similar issue can provide more details…

That’s odd, I’ve tested this on different browser’s in BrowserStack. Could you try to open up the devtools in IE11 and send a screenshot of any errors that you might see? Thanks for reporting!

@chriddyp Since I am not allowed to send any picture from my working laptop, I was thinking of typing everything I see in devtools. Then somehow, I fix this problem by deselect two options in ‘Changing compatibility view settings’. And, it works now!!!

Thanks, Chris!!!

Hi ihave the same issues right now can u tell me where u deselected the two options?

Upper right corner of IE, go to option. You can find compatibility view setting.

@ljw5122 @chriddyp

Hey, I am experiencing the same issue, but on Google Chrome. When I run the program, it works fine, but when I try to stop running the program, I have to manually go to command prompt, find the port and kill the connection. Otherwise, when I try to reload the program (or other dashboards), it will be perpetually loading. Is there a way to kill the connection automatically? I know with Flask that Ctrl + C kill the connection; finding a waitress equivalent or another workaround would be great

Hi all,

My dash doesn’t take neither threaded nor processess argument. My dash version is 1.9.1. Can you tell me what argument I should use to make one dash app accessible to multiple users?