Gunicorn issues... Loading js files fails

Hi all,
I have build my first Dash app and managed to serve it using nginx+gunicorn.
Recently I have tried to use other packages with mixed results. dash-auth and dash-bootstrap-components work fine. dash-leaflet, dash-more-components and dash-extensions are failing. Everything works fine on my development computer or if I run the app directly on the server (without gunicorn).
I’ve noticed that everything that is served from is working, but all locally served js files are a problem.
This is how I define the application (notice that serve_locally=False)

    application = dash.Dash(
            {'name':"viewport", 'content':"width=device-width, initial-scale=1"}

I have noticed that the on my development PC everything is being served locally (http://127:0.0.1/_dash_component_suites …etc…) even though serve_locally=False.

On gunicorn, everything that works is served remotely and the problematic js files are unsuccessfully trying to be found in the non-existent _dash-component-suites folder.

My best guess is from here:

When the app is deployed with gunicorn , it’ll switch to the CDN.

I suppose that the problematic packages are not published to then?

Any ideas?

Thanks in advance.