Announcing Dash Bio 1.0.0 🎉 : a one-stop-shop for bioinformatics and drug development visualizations.

Errors when trying to use pattern matching callbacks

I’m working on a relatively complex multi-page dash app with dynamic content. I’ve been getting weird behavior when trying to use pattern matching callbacks. So I tried out one of the simple examples given here in my current environment using debug mode and I get the following error:

Invalid argument `id` passed into Div with ID "[object Object]".
Expected `string`.
Was supplied type `object`.
Value provided: 
{
  "type": "dynamic-output",
  "index": 0
}

I’ve attached a screenshot of the error and my environment packages (I’m using Anaconda). Anyone know why its not working for me?


You’'ll need to upgrade Dash & it’s dependencies :slightly_smiling_face:

pip install dash --upgrade

Thank you for the quick response!
I am running the latest version of Dash (1.16.1) but I am using Conda and not pip to manage my environment. Are there known issues with Conda not including the correct dependent packages? When I tried to update dash through conda:

conda update dash

It just said everything was already up to date… I’m hoping to avoid mixing conda and pip.

p.s. your solution did work. But I"m still curious if there is a way to keep things updated using only conda?

I also wanted to confirm similar funny business from the conda version of Dash.

I had previously installed Dash from conda-forge (1.16.3) and developed a multi-tab app. I updated Dash (1.17.0) using conda and now the app behaves differently. The first initial tab doesn’t load on startup and I get a similar error to this one when I click on the tab to load it (I am using pattern matching callbacks to manage the tabs).

The problem I ran into is in trying to rollback my conda environment, it says that conda-forge no longer hosts the same Dash files I previously installed for 1.16.3 and doing an environment rollback is prevented.

The only way I got things working again was to uninstall all versions/dependencies of dash within my environment and re-install dash from pip as described here. I first tried reinstalling everything from conda, which resulted in the same errors.

@chriddyp did something recently change with how you guys are pushing things to be hosted on conda? Maybe it’s some issue with the noarch setup?

After installing via pip and having it working, I then tried installing via conda and this is all that conda installed:

The following NEW packages will be INSTALLED:

  dash               pkgs/main/noarch::dash-1.17.0-pyhd3eb1b0_0
  dash-core-compone~ pkgs/main/noarch::dash-core-components-1.3.1-py_0
  dash-html-compone~ pkgs/main/noarch::dash-html-components-1.0.1-py_0
  dash-renderer      pkgs/main/noarch::dash-renderer-1.1.2-py_0
  dash-table         pkgs/main/noarch::dash-table-4.4.1-py_0

This one install step caused my app to move from working (from the pip install) to exhibiting the funny broken behavior (from the conda install).