✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
🧬 Learn how to build RNA-Seq data apps with Python & Dash. Register for the May 20 Webinar!

Errors publishing from R 3.2.2 to plot.ly

Hi

I use plot.ly publishing from R. Recently I updated to R 3.2.2 (RStudio, Windows 10) and all its packages, and my old plot.ly scripts stopped working.

First, set_credentials_file(“username”, “api_key”) returns

Error: could not find function “set_credentials_file”

Later, my graphs are defined within plot.ly own language (first I created them with ggplot, then exported to plot.ly and finally copied the code from within plot.ly site, being the later the one i use in my R scripts).

I run the code ​py <- plotly(username=‘username’, key=‘api_key’) and returns

Storing ‘username’ as the environment variable 'plotly_username’
Storing ‘key’ as the environment variable 'plotly_api_key’
Warning messages:
1: ‘plotly’ is deprecated.
Use ‘ggplotly’ instead.
See help(“Deprecated”)
2: ‘plotly’ is deprecated.
Use ‘plot_ly’ instead.
See help(“Deprecated”)

Don’t understand if I have to use ggplotly or plot_ly in this command, or in the latter ones. Haven’t found help on this issue nowhere.

Then I define traces, data & layout before calling

response <- py$plotly(data, kwargs=list(filename = “filename”, fileopt = “overwrite”, layout=layout))

that returns Error: attempt to apply non-function

So finally what I have is a null empty object py and the graph is not updated at plotly site.

The same code works fine on R 3.2.1 (RStudio, Windows 8.1) with all packages updated.

Please can you help me or refer me to any usefull web content?

Thanks in advance

Hi @calidonia -
We made some changes to the package structure in our 1.0 and 2.0 releases. Check out https://plot.ly/r for the latest documentation and syntax.

Yeah, I saw that. But actually the R code provided by plot.ly GUI for every graph is unusable within last version of R. How do we solve this? Or have you planned to change the code provided there?

I’m getting the same error when I try to reproduce a chart from the code generated for R. It looks like this has been broken for almost a year. Are there plans to update this? This is a really valuable feature.

Hi there,
There are plans to update it (we’ve recently released version 4 of our R package and would like to update it to work with that), however I don’t have a timeline for the update at the moment.