DASH_DEBUG variable does not work

Did anyone experience this?

I defined

export DASH_DEBUG=True

from my Linux terminal and launched an app as app.run_server(host='localhost') but I see the debug mode off:

[alpha@home ~]$ ./app.py 
Dash is running on http://localhost:8050/

 * Serving Flask app 'app' (lazy loading)
 * Environment: production
   WARNING: This is a development server. Do not use it in a production deployment.
   Use a production WSGI server instead.
 * Debug mode: off

Here’s the documentation if you need it:

Hi all, can I get a reply to this issue?

Hi @tbillah,

I came across the same issue in the past. The environment variable is never checked because app.enable_dev_tools looks for it only if debug=None and debug defaults to False in app.run_server.

Setting app.run_server(debug=None) is a workaround for now.


Thank you so much. You solved the issue.

Hi @tbillah
Don’t forget to mark @jlfsjunior 's answer/post as the solution so the topic will appear solved.

1 Like

Okay just learnt how to do that, thank you Adam.

1 Like