Dash bootstrap component Modal not working in production environment

I have a dbc Modal component in my Python Dash webapp. While the Modal is open, I have a dash dcc interval running that triggers a callback that updates the text in the Modal.

All of this works fine locally on the standard werkzeug development server, but when I publish in an OpenShift environment the Modal never opens. I’m printing the text that should be shown in the Modal to the console as well and that seems to work fine.

I run my app with the following command:

CMD gunicorn --bind html_pagina:server -k gevent --worker-connections 10 --workers 4

I have tried running it on the development server, then the Modal does show up. It only doesn’t show up on when I run with the gunicorn command.

I’m using python3.9, dash 2.8.0 and dash bootstrap components 1.1.0. Updating is not easy since i’m using an image from our openshift enterprise instance.

Hi @lisatostrams ,

Have you tried setting the debug attribute to true like app.run(debug=True) and trying again to see if there are any warnings on the page?

oh, you may need this below, since you’re using gunicorn,