✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
⚡️ Concerned about the grid? Kyle Baranko teaches how to predicting peak loads using XGBoost. Register for the August webinar!

Dash app not rendering

Hi guys, i suddenly started having issues with my dash app created with python.When i launch my app i keep getting this error on my browser.

FileNotFoundError: [WinError 2] The system cannot find the file specified: ‘C:\ProgramData\Miniconda3\lib\site-packages\dash_renderer\prod’

Traceback:

Traceback (most recent call last):
File “C:\ProgramData\Miniconda3\lib\site-packages\flask\app.py”, line 2328, in call
return self.wsgi_app(environ, start_response)
File “C:\ProgramData\Miniconda3\lib\site-packages\flask\app.py”, line 2314, in wsgi_app
response = self.handle_exception(e)
File “C:\ProgramData\Miniconda3\lib\site-packages\flask\app.py”, line 1760, in handle_exception
reraise(exc_type, exc_value, tb)
File “C:\ProgramData\Miniconda3\lib\site-packages\flask_compat.py”, line 36, in reraise
raise value
File “C:\ProgramData\Miniconda3\lib\site-packages\flask\app.py”, line 2311, in wsgi_app
response = self.full_dispatch_request()
File “C:\ProgramData\Miniconda3\lib\site-packages\flask\app.py”, line 1827, in full_dispatch_request
self.try_trigger_before_first_request_functions()
File “C:\ProgramData\Miniconda3\lib\site-packages\flask\app.py”, line 1874, in try_trigger_before_first_request_functions
func()
File “C:\ProgramData\Miniconda3\lib\site-packages\dash\dash.py”, line 983, in _setup_server
self._generate_scripts_html()
File “C:\ProgramData\Miniconda3\lib\site-packages\dash\dash.py”, line 424, in _generate_scripts_html
)) + self._external_scripts + self._collect_and_register_resources(
File “C:\ProgramData\Miniconda3\lib\site-packages\dash\dash.py”, line 382, in _collect_and_register_resources
namespace=resource[‘namespace’]
File “C:\ProgramData\Miniconda3\lib\site-packages\dash\dash.py”, line 363, in _relative_url_path
modified = int(os.stat(module_path).st_mtime)
FileNotFoundError: [WinError 2] The system cannot find the file specified: ‘C:\ProgramData\Miniconda3\lib\site-packages\dash_renderer\prod’

Any help on what is going on here?

1 Like

sounds like your on the wrong python enviroment

same problem here, was you able to solve the problem?

Same problem, did anyone get the solution?

I encountered the same error message. I did some research and went back to the Dash Installation page, https://dash.plot.ly/installation and noticed the following:

Note : starting with dash 0.37.0, dash automatically installs dash-renderer, dash-core-components, dash-html-components, and dash-table, using known-compatible versions of each. You need not and should not install these separately any longer, only dash itself.

I executed these two commands at a Conda promt on Windows 10 to re-install with the latest versions.
pip install dash==1.4.1
pip install dash-daq==0.2.1

After that, the problem was resolved.

2 Likes

Thanks. This worked for me