Dash app does not deploy in Heroku

I am trying to deploy this dash app in Heroku. It does get built/deployed successfully:

enter image description here

but when I try to view it, it gives the following error:

enter image description here

Here is the application log:

enter image description here

The app runs fine on my local machine. So, what’s wrong and how can I fix it? I’m on Windows 10, if that’s relevant.

P.S.: I tried installing the Heroku API and deploy it from there; but heroku login produces the following error:

Error: unable to verify the first certificate

And heroku create app gives the following error:

 !    UNABLE_TO_VERIFY_LEAF_SIGNATURE: unable to verify the first certificate

So, I followed the steps from this tutorial to deploy the app from the Heroku website by connecting it manually to my Github repo.

I forked the repo in the tutorial link above and tried deplyoing it, and I can view the app! I copied the contents of requirements.txt from that repo into my app, and added the few more my app uses, but the error persists. So, what’s wrong with my app?

I have followed the following links (and more), and checked if I missed anything, but the issue persists:

Your logs suggest that gunicorn is not installed on the Heroku dyno

bash: gunicorn: command not found

however, it is in your requirements.txt, and that wasn’t the error when I cloned your repo and tried to deploy it myself. So check carefully which version of code you are deploying.

When I tried I had two errors.

  1. You import dash.dependencies.Event, but this was removed in Dash 0.36.0. Fortunately it seems you don’t actually use it, so you can just delete the import. More importantly, if you tested successfully locally that suggests you can’t have the same version of Dash installed locally that you specify in requirements.txt. Check that you have the same versions of packages on your machine that will be installed on Heroku
  2. The CSV you are trying to import doesn’t appear to exist: https://github.com/PrashantSaikia/Common-Scripts/blob/master/Address%20List%20All%20Companies.csv.

Because of 2) I couldn’t easily debug further, but hopefully that helps.


Hi @tcbegley. Thanks for your help, removing dash.dependencies.Event solved it. As I could not get Heroku CLI to get working on my machine (Windows 10), I could not see the log contents, and thereby discover the cause(s) of the issue. And I could not find the log content in the Heroku website where it mentioned these errors you mentioned.