Dash-ag-grid row grouping by date breaks value formatter

See here for background:

The date filter is now working, but when I try to create a row group based on date, the value formatter stops working and just displays this: “NaN/NaN/0NaN”.

I tried removing the aggregation/count text as I thought that might be breaking it, but that didn’t work. If I remove the value formatter (and just keep the valueGetter), the date is displayed and works as normal (example: Thu Feb 01 2024 00:00:00 GMT-0500 (Eastern Standard Time) )

I would just not use any valueGetters or formatters but the date picker does not work without it.
Really annoying and tricky to debug since it’s just a line of text. Is there any better way to debug these functions?


Update: I made a dagfuncs function that does not use d3 and instead uses the js Date (const date = new Date(Date.parse(value))) and toLocaleDateString.

Everything works now except now I notice the dates don’t sort properly when you put them in row grouping. But that has nothing to do with the value formatter as it breaks even just using the getter.

This is solved. I had to use a custom comparator for the dates.
I also updated to v31 which may help.


1 Like