Black Lives Matter. Please consider donating to Black Girls Code today.
https://www.blackgirlscode.com

Unable to connect falcon to chart studio Windows 10

Hello everyone.

I searched everywhere and I can’t find the answer to my problem. I’m trying to create a real-time graph with plotly in chart studio using a DB sqlite. When trying to upload my DB in to chart studio I was asked to install falcon in order to connect the sqlite DB to chart studio. I followed the instructions described in this link: https://plotly.com/chart-studio-help/database-connectors/personal-login/#step-3-install-falcon-(windows) which are quite simple.

My main issue is that in falcon app when selecting the tab “schedule” I get a little message that says: “Not logged in to Chart Studio Log In”:

Then I click in the “Log In” link which leads me to a two options selection. One of them is to log in to chart studio cloud and the other one to log in to chart studio enterprise. I select cloud option, then I click on “log in” blue button, and then my default web browser pops up with a message that says:

404 - Page not found
Oops! It looks like this page doesn’t exist.
Check the URL for errors or try refreshing the page.

If I check back falcon it says “authorizing…” and that’s it. I have tried different web browsers, manually copy-paste the link that falcon gave me to log in into chart studio, re-installing falcon, etc.

Another thing is that if I try to go the other way around and in my chart studio open a SQL data base it keeps asking me to install falcon. It’s like nobody told chart studio that I already installed falcon. Even if falcon is running in the background.

I’m running:
Windows 10 v1903 x64,
falcon v4.1.0,
Firefox 77

Please helppp

Since we changed the Chart Studio URL, you’ll need to use chart-studio.plotly.com as the Chart Studio Enterprise URL rather than the Chart Studio Cloud radio button. Sorry for the confusion!

Thanks for your quick answer. Unfortunately even with you suggested work around I can’t solve my issue. Maybe I’m doing something wrong. It looks like this:

And when the browser pops up, it looks like this:

I have also tried https://plotly.com, http://chart-studio.plotly.com, https://plotly.chart-studio.com without success

As a side note. The url that pops up has this format: https://chart-studio.plotly.com/o/authorize/?response_type=token&client_id=isFcew9naom2f1khSiMeAtzuOvHXHuLwhPsM7oPt&redirect_uri=http://localhost:9494/oauth2/callback

If I take the last part of the URL (i.e. http://localhost:9494/oauth2/callback) I get this message:

EDIT: I got it! The url that has to be set in the enterprise domain is: api.plot.ly

Anotación 2020-06-16 221643