✊🏿 Black Lives Matter. Please consider donating to Black Girls Code today.
⚾️ It's finally Baseball season! Root for the home team... & Register for our Sports Analytics Webinar!

Tables and colorlover issue in Jupyter Notebook

I’m trying to make tables for my dashboard (some simple tables, some with conditional formatting) and I am getting two errors in Jupyter Notebook that are preventing me from creating them.

The first is with Table. When I copied and pasted the example on this page it gave me this error:

AttributeError: module ‘plotly.graph_objs’ has no attribute ‘Table’

The second issue is with colorlover. When I follow the directions on this page, it says:

ModuleNotFoundError: No module named ‘colorlover’

I’ve imported several other modules without this problem. I tried installing colorlover with pip and pip3, both in Jupyter and on my machine. It keeps saying “Requirement already satisfied: colorlover in /Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages” for pip3 and then the same thing but python2.7 in the path for pip. But then it still gives the error.

Thanks in advance,
Barb

Still need help, but I think that I figured out what the problem might be. Every time I run:

plotly.version

in Jupyter Notebook it tells me ‘2.0.11’ and the Tables page implies that you need version 2.2.2. However, I have tried the following and it still shows 2.0.11:

pip install plotly --upgrade in my computer’s terminal
pip3 install plotly --upgrade in my computer’s terminal
!pip install plotly --upgrade in Jupyter Notebook
!pip3 install plotly --upgrade in Jupyter Notebook.

Any ideas how to get the upgrade to work in Jupyter Notebook?

I found an answer - I stopped using Jupyter notebook. After unsuccessfully trying to uninstall plotly and reinstall it and a bunch of other things like forcing the version, I just gave up. As soon as I switched to PyCharm it worked.