Running JupterDash in JupyterLab


I’ve run into an issue running JupterDash inside of Jupyter lab. When I run the JupyterDash.infer_jupyter_proxy_config() I get this error:

AttributeError Traceback (most recent call last)
----> 1 JupyterDash.infer_jupyter_proxy_config()

~/.local/lib/python3.8/site-packages/jupyter_dash/ in infer_jupyter_proxy_config(cls)
80 else:
81 # Assume classic notebook or JupyterLab
—> 82 _request_jupyter_config()
84 def init(self, name=None, server_url=None, **kwargs):

~/.local/lib/python3.8/site-packages/jupyter_dash/ in _request_jupyter_config(timeout)
47 return
—> 49 _send_jupyter_config_comm_request()
51 # Get shell and kernel

~/.local/lib/python3.8/site-packages/jupyter_dash/ in _send_jupyter_config_comm_request()
18 if IPython.get_ipython() is not None:
19 if _dash_comm.kernel is not None:
—> 20 _caller[“parent”] = _dash_comm.kernel.get_parent()
21 _dash_comm.send({
22 ‘type’: ‘base_url_request’

AttributeError: ‘IPythonKernel’ object has no attribute ‘get_parent’`

It seems I am able to spin up a dash server no problem but accessing it it the issue. I tried using the GitHub - jupyterhub/jupyter-server-proxy: Jupyter notebook server extension to proxy web services. project but it doesn’t seem to work.

Any help would be much appreciated! Would love to use Dash in Jupyter.