Announcing Dash Bio 1.0.0 🎉 : a one-stop-shop for bioinformatics and drug development visualizations.

Inexplicable amount of package conflicts trying to install Plotly 5.5 with Conda

I’m a total noob when it comes to environments and packages and such, what is going on here, I have plotly 5.1 installed probably via anaconda, I don’t really do much to manage environments, Im trying to upgrade to plotlt 5.5 and it is giving me a million issues and taking forever, just won’t work:

See the below… I’m guessing there is something other than a normal set of conflicts going on? This is only like 1/5th of the ful error report…

THank you!!!
Rajko

Package libboost conflicts for:
arrow-cpp → boost-cpp → libboost[version=‘1.65.1|1.65.1|1.65.1|1.67.0|1.67.0|1.71.0|1.73.0’,build=‘vc14h7b94727_3|h95ae18b_4|hfd51bdf_4|h6c2663c_11|h33f27b4_11|ha9fde0e_0|h86230c1_4|vc9h83875ae_3’]
arrow-cpp → libboost[version=’>=1.65.1,<1.65.2.0a0|>=1.67.0,<1.67.1.0a0|>=1.73.0,<1.73.1.0a0’]
boost-cpp → libboost[version=‘1.65.1|1.65.1|1.65.1|1.67.0|1.67.0|1.71.0|1.73.0’,build=‘vc14h7b94727_3|h95ae18b_4|hfd51bdf_4|h6c2663c_11|h33f27b4_11|ha9fde0e_0|h86230c1_4|vc9h83875ae_3’]
pyarrow → arrow-cpp[version=’>=4.0.1,<4.0.2.0a0’] → libboost[version=‘1.65.1|1.65.1|1.65.1|1.67.0|1.67.0|1.71.0|1.73.0|1.73.0|>=1.73.0,<1.73.1.0a0|>=1.67.0,<1.67.1.0a0|>=1.65.1,<1.65.2.0a0’,build=‘vc14h7b94727_3|h95ae18b_4|hfd51bdf_4|h6c2663c_11|h33f27b4_11|ha9fde0e_0|h86230c1_4|vc9h83875ae_3’]

Package python-libarchive-c conflicts for:
conda-package-handling → python-libarchive-c
conda-verify → conda-package-handling[version=’>=1.0.4’] → python-libarchive-c
conda[version=’>=4.11.0’] → conda-package-handling[version=’>=1.3.0’] → python-libarchive-c
conda-build → python-libarchive-c
anaconda==2021.11=py39_0 → python-libarchive-c==2.9=pyhd3eb1b0_1

Package path conflicts for:
anaconda==2021.11=py39_0 → path.py==12.5.0=hd3eb1b0_0 → path
anaconda==2021.11=py39_0 → path==16.0.0=py39haa95532_0
path.py → path[version=’<13.2’]

Package jaraco.itertools conflicts for:
importlib_metadata → zipp[version=’>=0.5’] → jaraco.itertools
zipp → jaraco.itertools
importlib-metadata → zipp[version=’>=0.5’] → jaraco.itertools

Package mypy_extensions conflicts for:
anaconda==2021.11=py39_0 → mypy_extensions==0.4.3=py39haa95532_0
anaconda==2021.11=py39_0 → black==19.10b0=py_0 → mypy_extensions
black → mypy_extensions
pyls-black → black → mypy_extensions

Package utf8proc conflicts for:
arrow-cpp → utf8proc
pyarrow → arrow-cpp[version=’>=4.0.1,<4.0.2.0a0’] → utf8proc

Package libsodium conflicts for:
jupyter_client → pyzmq[version=’>=13’] → libsodium[version=’>=1.0.16,<1.0.17.0a0’]
spyder → pyzmq[version=’>=17’] → libsodium[version=’>=1.0.16,<1.0.17.0a0’]
spyder-kernels → pyzmq[version=’>=17’] → libsodium[version=’>=1.0.16,<1.0.17.0a0’]
notebook → pyzmq[version=’>=17’] → libsodium[version=’>=1.0.16,<1.0.17.0a0’]
pyzmq → zeromq[version=’>=4.3.3,<4.3.4.0a0’] → libsodium[version=’>=1.0.18,<1.0.19.0a0’]
qtconsole → pyzmq[version=’>=17.1’] → libsodium[version=’>=1.0.16,<1.0.17.0a0’]
jupyter_server → pyzmq[version=’>=17’] → libsodium[version=’>=1.0.16,<1.0.17.0a0’]
pyzmq → libsodium[version=’>=1.0.16,<1.0.17.0a0’]
zeromq → libsodium[version=’>=1.0.16,<1.0.17.0a0|>=1.0.18,<1.0.19.0a0’]

Package aws-c-common conflicts for:
aws-c-event-stream → aws-checksums[version=’>=0.1.9,<0.1.10.0a0’] → aws-c-common[version=’>=0.4.59,<0.4.60.0a0’]
arrow-cpp → aws-sdk-cpp[version=’>=1.8.185,<1.8.186.0a0’] → aws-c-common[version=’>=0.4.57,<0.4.58.0a0’]
aws-sdk-cpp → aws-c-common[version=’>=0.4.57,<0.4.58.0a0’]
aws-checksums → aws-c-common[version=’>=0.4.57,<0.4.58.0a0|>=0.4.59,<0.4.60.0a0|>=0.4.65,<0.4.66.0a0’]
aws-c-event-stream → aws-c-common[version=’>=0.4.57,<0.4.58.0a0’]

Package qtawesome conflicts for:
anaconda==2021.11=py39_0 → spyder==5.1.5=py39haa95532_1 → qtawesome[version=’>=1.0.2’]
spyder → qtawesome[version=’>=0.4.1|>=0.5.7|>=1.0.2’]
anaconda==2021.11=py39_0 → qtawesome==1.0.2=pyhd3eb1b0_0

Package mpmath conflicts for:
anaconda==2021.11=py39_0 → mpmath==1.2.1=py39haa95532_0
anaconda==2021.11=py39_0 → sympy==1.9=py39haa95532_0 → mpmath[version=’>=0.19’]
sympy → mpmath[version=’>=0.19’]

Package libaec conflicts for:
tifffile → imagecodecs[version=’>=2021.4.28’] → libaec[version=’>=1.0.4,<2.0a0’]
anaconda==2021.11=py39_0 → libaec==1.0.4=h33f27b4_1
imagecodecs → libaec[version=’>=1.0.4,<2.0a0’]
anaconda==2021.11=py39_0 → imagecodecs==2021.8.26=py39ha1f97ea_0 → libaec[version=’>=1.0.4,<2.0a0’]

Package pyreadline conflicts for:
anaconda==2021.11=py39_0 → pyreadline==2.1=py39haa95532_1
h5py → pyreadline
anaconda==2021.11=py39_0 → h5py==3.2.1=py39h3de5c98_0 → pyreadline

Package grpc-cpp conflicts for:
pyarrow → grpc-cpp[version=’>=1.26.0,<1.27.0a0’]
arrow-cpp → grpc-cpp[version=’>=1.26.0,<1.27.0a0’]
pyarrow → arrow-cpp[version=’>=4.0.1,<4.0.2.0a0’] → grpc-cpp

Package python_abi conflicts for:
jupyter_highlight_selected_word → python_abi=3.8[build=_cp38]
jupyter_contrib_nbextensions → jupyter_highlight_selected_word[version=’>=0.1.1’] → python_abi=3.8[build=
_cp38]
jupyter_nbextensions_configurator → python_abi=3.8[build=*_cp38]

Package zope.interface conflicts for:
anaconda==2021.11=py39_0 → zope.interface==5.4.0=py39h2bbff1b_0
attrs → zope.interface
gevent → zope.interface
pytest → attrs[version=’>=17.2.0’] → zope.interface
prometheus_client → twisted → zope.interface[version=’>=4.0.2|>=4.4.2’]
anaconda==2021.11=py39_0 → gevent==21.8.0=py39h2bbff1b_1 → zope.interface

Package et_xmlfile conflicts for:
anaconda==2021.11=py39_0 → openpyxl==3.0.9=pyhd3eb1b0_0 → et_xmlfile
anaconda==2021.11=py39_0 → et_xmlfile==1.1.0=py39haa95532_0
openpyxl → et_xmlfile

Package brotlipy conflicts for:
urllib3 → brotlipy[version=’>=0.6.0’]
anaconda==2021.11=py39_0 → brotlipy==0.7.0=py39h2bbff1b_1003
anaconda==2021.11=py39_0 → urllib3==1.26.7=pyhd3eb1b0_0 → brotlipy[version=’>=0.6.0’]
requests → urllib3[version=’>=1.21.1,<1.27’] → brotlipy[version=’>=0.6.0’]

Package dask conflicts for:
anaconda==2021.11=py39_0 → dask==2021.10.0=pyhd3eb1b0_0
scikit-image → dask[version=’>=0.5’]

Package conda-env conflicts for:
conda-token → conda[version=’>=4.3’] → conda-env[version=’>=2.6’]
conda-build → conda[version=’>=4.5’] → conda-env[version=’>=2.6’]

Package jupyter_server conflicts for:
jupyterlab → jupyter_server[version=’>=1.4,<2’]
jupyterlab_server → jupyter_server[version=’>=1.1.0,<2.0.0|>=1.4,<2’]
jupyterlab → jupyterlab_server[version=’>=2.3,<3’] → jupyter_server[version=’>=1.0.1,<2.0.0|>=1.1.0,<2.0.0’]
nbclassic → jupyter_server[version=’>=1.0.1,<2.0.0’]
anaconda==2021.11=py39_0 → jupyterlab==3.2.1=pyhd3eb1b0_1 → jupyter_server[version=’>=1.0.1,<2.0.0|>=1.4,<2’]
anaconda==2021.11=py39_0 → jupyter_server==1.4.1=py39haa95532_0
_ipyw_jlab_nb_ext_conf → jupyterlab → jupyter_server[version=’>=1.4,<2’]

Package funcsigs conflicts for:
astropy → pytest[version=’<4’] → funcsigs[version=’>=1.0’]
pytables → mock → funcsigs
numba → funcsigs
pytest → funcsigs[version=’>=1.0’]
mock → funcsigs

Package pexpect conflicts for:
anaconda==2021.11=py39_0 → pexpect==4.8.0=pyhd3eb1b0_3
anaconda==2021.11=py39_0 → spyder==5.1.5=py39haa95532_1 → pexpect[version=’>=4.4.0’]
spyder → pexpect[version=’>=4.4.0’]

Package filelock conflicts for:
conda-build → filelock
anaconda==2021.11=py39_0 → filelock==3.3.1=pyhd3eb1b0_1

Package flake8-import-order conflicts for:
pygithub → pyjwt[version=’<2.0’] → flake8-import-order
pyjwt → flake8-import-order
oauthlib → pyjwt[version=’>=1.0.0’] → flake8-import-order

Package watchdog conflicts for:
anaconda==2021.11=py39_0 → watchdog==2.1.3=py39haa95532_0
spyder → watchdog[version=’>=0.10.3|>=0.10.3,<2.0.0’]
anaconda==2021.11=py39_0 → spyder==5.1.5=py39haa95532_1 → watchdog[version=’>=0.10.3’]

Package sphinxcontrib-devhelp conflicts for:
spyder → sphinx[version=’>=0.6.6’] → sphinxcontrib-devhelp
anaconda==2021.11=py39_0 → sphinxcontrib-devhelp==1.0.2=pyhd3eb1b0_0
numpydoc → sphinx → sphinxcontrib-devhelp
sphinx → sphinxcontrib-devhelp
anaconda==2021.11=py39_0 → sphinx==4.2.0=pyhd3eb1b0_1 → sphinxcontrib-devhelp

Package zope.event conflicts for:
gevent → zope.event
anaconda==2021.11=py39_0 → zope.event==4.5.0=py39haa95532_0
anaconda==2021.11=py39_0 → gevent==21.8.0=py39h2bbff1b_1 → zope.event

Package backports.tempfile conflicts for:
conda-verify → backports.tempfile
conda-build → conda-verify → backports.tempfile

Package cython conflicts for:
nltk → gensim → cython==0.29.23
anaconda==2021.11=py39_0 → cython==0.29.24=py39h604cdb4_0

Package werkzeug conflicts for:
anaconda==2021.11=py39_0 → flask==1.1.2=pyhd3eb1b0_0 → werkzeug[version=’>=0.15’]
flask → werkzeug[version=’>=0.14|>=0.15|>=2.0|>=0.7,<1.0.0’]
anaconda==2021.11=py39_0 → werkzeug==2.0.2=pyhd3eb1b0_0

Package blinker conflicts for:
oauthlib → blinker[version=’>=1.4.0’]
requests-oauthlib → oauthlib[version=’>=3.0.0’] → blinker[version=’>=1.4.0’]

Package double-conversion conflicts for:
pyarrow → arrow-cpp[version=’>=4.0.1,<4.0.2.0a0’] → double-conversion
arrow-cpp → double-conversion

Package keyring conflicts for:
anaconda==2021.11=py39_0 → spyder==5.1.5=py39haa95532_1 → keyring[version=’>=17.0.0’]
spyder → keyring[version=’>=17.0.0’]
anaconda==2021.11=py39_0 → keyring==23.1.0=py39haa95532_0

Package pkginfo conflicts for:
anaconda==2021.11=py39_0 → pkginfo==1.7.1=py39haa95532_0
conda-build → pkginfo

Package pycrypto conflicts for:
paramiko → pycrypto[version=’>=2.1,!=2.4,<3.0’]
spyder → paramiko → pycrypto[version=’>=2.1,!=2.4,<3.0’]

Package tblib conflicts for:
distributed → tblib[version=’>=1.6.0’]
anaconda==2021.11=py39_0 → distributed==2021.10.0=py39haa95532_0 → tblib[version=’>=1.6.0’]
dask → distributed=2021.10.0 → tblib[version=’>=1.6.0’]
anaconda==2021.11=py39_0 → tblib==1.7.0=pyhd3eb1b0_0

Package jupyter-packaging conflicts for:
_ipyw_jlab_nb_ext_conf → jupyterlab → jupyter-packaging[version=’>=0.7.3,<0.8.0’]
jupyterlab → jupyter-packaging[version=’>=0.7.3,<0.8.0’]

Package py-lief conflicts for:
conda-build → py-lief
anaconda==2021.11=py39_0 → py-lief==0.10.1=py39hd77b12b_1

Package bkcharts conflicts for:
bokeh → bkcharts[version=’>=0.2’]
dask → bokeh → bkcharts[version=’>=0.2’]
anaconda==2021.11=py39_0 → bkcharts==0.2=py39haa95532_0

Package blosc conflicts for:
tifffile → imagecodecs[version=’>=2021.4.28’] → blosc[version=’>=1.20.1,<2.0a0|>=1.21.0,<2.0a0’]
imagecodecs → blosc[version=’>=1.20.1,<2.0a0|>=1.21.0,<2.0a0’]
anaconda==2021.11=py39_0 → imagecodecs==2021.8.26=py39ha1f97ea_0 → blosc[version=’>=1.20.1,<2.0a0|>=1.21.0,<2.0a0’]
pytables → blosc[version=’>=1.14.3,<2.0a0|>=1.14.4,<2.0a0|>=1.15.0,<2.0a0|>=1.16.3,<2.0a0|>=1.20.1,<2.0a0’]
anaconda==2021.11=py39_0 → blosc==1.21.0=h19a0ad4_0

Package typing-extensions conflicts for:
astroid → typing-extensions[version=’>=3.10|>=3.7.4’]
pylint → astroid[version=’>=2.9.0,<2.10’] → typing-extensions[version=’>=3.10|>=3.7.4’]

Package aws-sdk-cpp conflicts for:
pyarrow → arrow-cpp[version=’>=4.0.1,<4.0.2.0a0’] → aws-sdk-cpp[version=’>=1.8.133,<1.8.134.0a0|>=1.8.156,<1.8.157.0a0|>=1.8.185,<1.8.186.0a0’]
arrow-cpp → aws-sdk-cpp[version=’>=1.8.133,<1.8.134.0a0|>=1.8.156,<1.8.157.0a0|>=1.8.185,<1.8.186.0a0’]

it also gives this report initally…

Hi @nolefp
Welcome to the community.
Do you have to use anaconda for this? I found it a lot easier to manage environments and update libraries through pycharm or directly in the command line.

I have a video I haven’t uploaded to YouTube yet, about working with pycharm and environments. I can send you that if you’re interested.

That would be great, thank you!

In the meantime, if anyone knows how to solve with Conda, would be very helpful, thank you!!