Graph has no interaction when embedded with HTML and doesn't show up at all when embedded with iframe

Hi there,

I’m sorry if this is too easy or obvious of a enquiry, but I am using Plotly for a coursework and have made the following graph:
https://plot.ly/~luptilu/10/?share_key=IKhWKeRGxX8vLhQCohoJ1o and am experiencing problems. A fellow classmate is having the same issue, so I thought I would ask here about it.

When I try embedding my graph into my html file with the html code, it shows up as a static image (no interaction) and looks kind of pixelated, and when I try embedding it with the iframe code, it doesn’t show up at all, saying “It may have been moved or deleted :(” on a grey background.

Is there maybe something I have to add to the head of my HTML document to make it work?
Or could it have somehing to do with the fact that my HTML file is only saved as a local file on my computer thus far?

Thank you for any help, I am very lost.

X

Luisa

Hello Plotly team,

I am experiencing this exact same issue. Any known fixes?

Thanks,
Jaydeep

Okay so the problem here is that the URL that is given to the source tag (src) of the iframe is invalid.

Solution is to open go to plotly website and open your profile, then open the exact plot you want to display, but click in the Viewer button. When the plot viewer window opens, there will be a few buttons somewhere on the top right side. Make you share your plot to be public. Click the ‘Full Window’ preview button, which should open the plot in a new window, and the url that is being used for that new window should be placed in the source of the iframe.

For example, this is the issue that I was facing…

The src plotly was putting in the iframe was:
//plot.ly/~jrmistry/131.embed

The src url plotly should have used was: