Black Lives Matter. Please consider donating to Black Girls Code today.
Learn how to use COVID-19 data in open source Dash apps. Register for the Sept 23rd webinar with IQT!

Error 400, MSSQL DB Query

I am trying to run the query:


Which works in Sql Server Management Studio and returns the correct 10 results.
But I get this error message:

ERROR {“status”:400,“content”:{“error”:{“message”:“Incorrect syntax near ‘.’.”}}}

I don’t have any of those characters in my query.

I was able to successfully run the same query in the Chart studio, just not in the Falcon SQL Client.

@n-riesco have you seen this before?

I’ve opened and issue on github to track this problem. See .

@ywamships Would it be OK for you to post the table definition here?

@ywamships We’ve got a pre-release of Falcon here that upgrades the library to connect to a MSSQL server. Would you be able to test if this problem is still present, please?

Just installed 2.3.3 beta 1, still get same error running same query.

Since I can’t reproduce this issue, I’d need access to Falcon’s log file. I’m hesitant to ask you to upload it here, because although it doesn’t contain passwords, it will contain user and host names.

If you feel brave enough, you can find the log file in %userprofile%\.plotly\connector\log.log. Although the extension is log is actually a JSON file (you’d need a JSON viewer to open it). Ideally, to minimise noise, you’d delete log.log before opening Falcon, then run the query, close Falcon and investigate the contents of log.log.

I’m planning to add a log viewer to Falcon for cases like this (see