Black Lives Matter. Please consider donating to Black Girls Code today.
Learn how to use COVID-19 data in open source Dash apps. Register for the Sept 23rd webinar with IQT!

Deploying Dash on Azure

Hi all,

I am having trouble deploying a simple dash app on Azure Web App Services. I basically followed the tutorial at:

When the tutorial is speaking about heroku, I am deviating. Basically, I simply have a, requirements.txt, and a runtime.txt file. Then I push these files to the deployment git repository according to:

However, I just can’t access the website afterwards, even though the deployment process works totally fine. On the frontend, I receive “You do not have permission to view this directory or page.” and when I check the backend logs, I can see something like “The Web server is configured to not list the contents of this directory” and “A default document is not configured for the requested URL, and directory browsing is not enabled on the server.”. Interestingly, I can’t find a web.config file on the server, even though it should be created automatically.

Anyone has an idea? Thanks!

1 Like

Have you made any progress on this issue? I’m trying to deploy a Dash app to Google cloud but haven’t gotten it to work yet either.

I ended up setting up my own deployment virtual machine that I then deployed the app on. I like having things under my control and it worked quite easily in the end with e.g., docker and flask deployment.

It worked though as well with heroku as I think was explained in the doku of dash.