Dash Stops Responding Even Upon Restart


So this is the second time I run into this issue. I added a change into my app that broke it, and I got ‘Error Loading Dependencies’. So I remove the changes and restart the app, but that is the only message I get, EVEN THOUGH I am running a version that was perfectly functional before.

This is what happens on chrome, Explorer gives me the following error

Worth mentioning that the last time I ran into this issue, I changed the PC I was working on altogether, but I cannot afford to do that everytime something goes bonkers :smiley:

Thank youu!

For me, Error loading dependencies is usually caused by dependency loops in my callback functions, i.e. callback A triggers callback B which triggers callback C, which then triggers callback A again. The app will endlessly run those functions if there is a dependency loop, so Dash won’t let it start if it detects a dependency loop.

In Chrome, something that helps me in this scenario is to go to developer tools by hitting Ctrl+Shift+J on Windows or Cmd+Opt-J on a Mac. You may be able to see the problem in the Console.