Dash and vaex together causing memory error with multiple callbacks

Hello Everyone
I have been using dash for so long.
Recently i tried vaex which was awesome to work with larger dataframes. And i do feel if vaex is used with dash then it will help in reducing the time of calculations in callbacks.

But when i used vaex with dash i encountered memory error. Mostly the memory error is ocurring when i’m using multiple callbacks.
Also whenever i run a vaex query in my separate anaconda script it runs quickly but when i run it in dash callbacks it slows down upto a few seconds.

Sorry my code is too long and i think i can replicate it all right now.
But i think I’m missing something. Maybe the Asynchio is used both by dash and vaex which is causing some problem.

thanks in advance.

Hi @bsbalkar,

I’m also using the awesome vaex for some of my Dash app, doing filters and aggregations essentially. I have not found any incompatibility or performance issue with Dash. Maybe try to sort out which part of your code is causing the memory spike, with the help of Python profiler packages, such as memory-profiler or scalene.