Black Lives Matter. Please consider donating to Black Girls Code today.
Learn how to use COVID-19 data in open source Dash apps. Register for the Sept 23rd webinar with IQT!

Annotations disappear in scatter3d after hover off then on

Hi there,

I have a scatter3d chart with a pretty long annotation text (posted in my plot.ly account under username dmitrys).

I noticed that pressing hover off then hover on button erases my annotation text completely. This happens both with offline html and online from an account with plot.ly. I tried it with Chrome v54 and Opera v15 and the problem persisted.

Possibly related: my company manages settings in Internet Explorer, restricting scripts and ActiveX.
When I tried the same with IE 11, it asked me if I wanted to allow blocked content. I chose “Allow” and my scatted3d appeared but without annotations.

Please advise.

For the record, it is possible to disable some buttons in plotly modebar using modeBarButtonsToRemove config setting, which is probably the quickest workaround for anyone experiencing similar problem.